What browsers are supported

TalentLMS is compatible with all modern browsers including Firefox, IE 9+, Chrome, Safari and Opera. It is also compatible with browsers of recent mobile devices (IOS and Android) 

Whenever we detect an older browser we prompt the end-user to update the browser to get the best possible experience.

The decision to avoid old browsers was made to improve the quality, interface, stability and security of the final product since older browsers did not properly supported HTML5 among other standards. We strongly advice you to upgrade your browser anyway to enjoy a better internet experience.

Feedback and Knowledge Base